Cannot stop the running behavior in Choregraphe

Gepostet 9 Monate her von Reji Joseph

Ein Thema veröffentlichen
Nicht beantwortet

After a behavior is being uploaded to the Nao V6, the only way to stop the behavior is to disconnect from the network. Is there a fix for this? I am using Chorepgraphe 2.8.6 and Nao V6.

0 Stimmen


3 Kommentare

Sortiert nach
A

Admin Corvinianum gepostet 3 Monate her

I tested a little bit around and this seems to be related to firewall problems. Maybe someone can check on this: if we are within the same network, everything works fine. If there is a firewall (opnsense in our case) in between, even if ports are forwarded, it is not working.


Same happens to a virtual robot if it is not on the same network: there is just no response arriving at choregraphe. It runs the first behaviour and then looses contact. Let the robot speak something it will not show in the simulation probably for the same reason.

 

Maybe naoqi is using some mechanism for sending back information that needs a different setup than just forwarding port 9559.



Sadly the documentation does not say anything about this, so we are stabbing in the dark somehow. So I am thankful for any idea!


Best regards

Thomas

0 Stimmen

T

Tom Davies gepostet 5 Monate her

Me too, sometimes additonally a behaviour will show as running in choregraphe but when I try to activate individual boxes it says the behaviour is not running. Neither Stopping nor Playing the behaviour has any effect.

0 Stimmen

J

JMOlaf gepostet 7 Monate her

I have the same problem. Using Choregraphe 2.8.6 on Win 11 and NAO V6

0 Stimmen

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen