Python API Future Development

Posted 16 days by Richard Williams

Post a topic
Un Answered
R
Richard Williams

Hi, 

I've got quite a significant project (2 million lines) based on NAOqi Python 2.5 and my questions are two fold:


1. Is it possible to downgrade a pepper running NAOqi 2.9 so I can run this application on a real robot? 

2. Are their plans to release a new (Python 3) API for NAOqi 2.9? It would be easier to port this to Python 3 than port everything to Java/Android. 


Thanks


Richard

0 Votes


1 Comments

C

Clement Portales posted 15 days Admin

Hello Richard, 


1. It is possible to downgrade your Pepper running NAOqi 2.9 to 2.5, but it requires swapping a tablet and therefore sending your robot back to a repair center. You can open a ticket to ask what would be the leadtime to do it. 

2. As of now, there are unfortunately no plans to release a Python 3 API for NAOqi 2.9. United Robotics has yet to make a communication on the development plans for Pepper. 


Best,

Clement

0 Votes

Login or Sign up to post a comment